thanks for the snapshot.
I dont have this line between.
only the extended keyboard and then the keyboard.
I thought the snippets button was combined with the "extended keyboard"?

but your tip show me the right direction!
general->keyboard->"predictive" was disabled!

I enabled it and now I can see the snippet button.

thanks to all for the great support :)