Looking at setup.py:

install_requires = requests[security] numpy scipy matplotlib pandas pillow pyglet pyopengl soundfile sounddevice python-bidi arabic_reshaper cffi future json_tricks pyosf xlrd openpyxl pyserial pyyaml gevent msgpack-numpy msgpack-python psutil tables pyzmq moviepy opencv-python python-gitlab gitpython astunparse esprima freetype-py # Platform-specific dependencies. imageio < 2.5; python_version < "3" imageio >= 2.5; python_version >= "3" imageio-ffmpeg; python_version >= "3" pyparallel; platform_system == "Linux" pyWinhook; platform_system == "Windows" pyqmix >= 2018.12.13; platform_system == "Windows" pyqt5; python_version >= "3" wxPython != 4.0.2, != 4.0.3; platform_system != "Linux" pypiwin32; platform_system == "Windows" pyobjc-core; platform_system == "Darwin" pyobjc-framework-Quartz;

A good fraction of these are incompatible with pythonista. For instance scipy.