• jh2020

    I’m trying to install gmpy2. But, I get the following error when using pip install gmpy2.

    Querying PyPI ...
    Downloading package ...
    Opening: https://files.pythonhosted.org/packages/26/37/2184c13cee81e1dbeaebbb13570195247e73ab2138a3db0c9d2c5347e372/gmpy-1.17.zip

    Save as: /private/var/mobile/Containers/Data/Application/7399F6D4-CF53-4A0F-B1F6-53BFC656AF4F/tmp//gmpy-1.17.zip (147636 bytes)
    [====================] 100.00% | 144.2KiB
    Extracting archive file ...
    Running setup file ...
    WARNING: Extension modules are skipped: [<distutils.extension.Extension('gmpy') at 0x11203cb38>]
    PipError('failed to find packages or py_modules arguments in setup call',)
    Failed to run setup.py
    Fall back to directory guessing ...
    Error: Cannot locate packages. Manual installation required.

    What an I doing wrong? Any help would be greatly appreciated.

    posted in Pythonista read more

Internal error.

Oops! Looks like something went wrong!