• pap

    Using on iphone 12
    Data storage in this iphone files

    Hi I am new in Pythonista and have used stash to install a new package called yfinance (yahoo finance).

    When installing packages i notice this kind of error:

    Extracting archive file ...
    Archive extracted.
    Running setup file ...
    Building lxml version 4.9.1.
    Building without Cython.
    PermissionError(1, 'Operation not permitted')
    Failed to run setup.py
    Fall back to directory guessing ...
    Package installed: lxml

    Then when I import yfinance i get the following errors. Could some one guide me?

    Traceback (most recent call last):
    File "/private/var/mobile/Containers/Shared/AppGroup/1B45CCD7-E90A-4984-8868-7DD3DAF2F102/Pythonista3/Documents/test.py", line 1, in <module>
    import yfinance as yf
    File "/private/var/mobile/Containers/Shared/AppGroup/1B45CCD7-E90A-4984-8868-7DD3DAF2F102/Pythonista3/Documents/site-packages-3/yfinance/init.py", line 23, in <module>
    from .ticker import Ticker
    File "/private/var/mobile/Containers/Shared/AppGroup/1B45CCD7-E90A-4984-8868-7DD3DAF2F102/Pythonista3/Documents/site-packages-3/yfinance/ticker.py", line 27, in <module>
    import pandas as _pd
    File "/private/var/mobile/Containers/Shared/AppGroup/1B45CCD7-E90A-4984-8868-7DD3DAF2F102/Pythonista3/Documents/site-packages-3/pandas/init.py", line 22, in <module>
    from pandas.compat.numpy import (
    File "/private/var/mobile/Containers/Shared/AppGroup/1B45CCD7-E90A-4984-8868-7DD3DAF2F102/Pythonista3/Documents/site-packages-3/pandas/compat/numpy/init.py", line 21, in <module>
    "this version of pandas is incompatible with numpy < 1.15.4\n"
    ImportError: this version of pandas is incompatible with numpy < 1.15.4
    your numpy version is 1.8.0.
    Please upgrade numpy to >= 1.
    15.4 to use this pandas version

    posted in Pythonista read more

Internal error.

Oops! Looks like something went wrong!