• puckypuck

    This regex is killing me.
    I have reinstalled pythonista, again the message no module regex.
    tryed pip install regex and get a setup.py error message

    Sorry for the many questions, and this is the last time before i give up.

    [~/Documents]$ pip install regex
    Querying PyPI ...
    Downloading package ...
    Opening: https://files.pythonhosted.org/packages/73/d9/b58289d885180b5d538aa6df07974b5fe6088547ac846c0f76f77259c304/regex-2020.1.8.tar.gz

    Save as: /private/var/mobile/Containers/Data/Application/E4F4BB3B-DCD1-4E68-9C70-3BE1281A906D/tmp//regex-2020.1.8.tar.gz (681106 bytes)
    681106 [100.00%]
    Extracting archive file ...
    Archive extracted.
    Running setup file ...
    WARNING: Extension modules are skipped: [<main.OmniClass object at 0x1155afb38>]
    PipError('cannot locate source folder/file: /private/var/mobile/Containers/Data/Application/E4F4BB3B-DCD1-4E68-9C70-3BE1281A906D/tmp/2cc8cbdf6ff94fec933154320700e076/regex-2020.1.8/regex.py',)
    Failed to run setup.py
    Fall back to directory guessing ...
    Error: Cannot locate packages. Manual installation required.
    [~/Documents]$

    posted in Pythonista read more
  • puckypuck

    @JonB

    Ok i cleaned my side packages.

    ============================= test session starts ==============================
    platform ios -- Python 3.6.1, pytest-3.0.5, py-1.4.32, pluggy-0.4.0 -- /private/var/containers/Bundle/Application/79823AB3-8B78-4BFE-85AA-07A6911F8A59/Pythonista3.app/Pythonista3
    rootdir: /private/var/mobile/Containers/Shared/AppGroup/09B9F2A0-A8A6-48F9-A9FF-5270C93BC17E/Pythonista3/Documents, inifile:
    collecting ... collected 0 items / 1 errors

    generated xml file: /private/var/mobile/Containers/Shared/AppGroup/09B9F2A0-A8A6-48F9-A9FF-5270C93BC17E/Pythonista3/Documents/.pythonista_pytest_log.xml
    ==================================== ERRORS ====================================
    __________________________ ERROR collecting test2.py ___________________________
    ImportError while importing test module '/private/var/mobile/Containers/Shared/AppGroup/09B9F2A0-A8A6-48F9-A9FF-5270C93BC17E/Pythonista3/Documents/test2.py'.
    Hint: make sure your test modules/packages have valid Python names.
    Traceback:
    test2.py:5: in <module>
    from binance.client import Client
    site-packages-3/binance/client.py:8: in <module>
    from .helpers import date_to_milliseconds, interval_to_milliseconds
    site-packages-3/binance/helpers.py:3: in <module>
    import dateparser
    site-packages-3/dateparser/init.py:4: in <module>
    from .date import DateDataParser
    site-packages-3/dateparser/date.py:10: in <module>
    import regex as re
    E ModuleNotFoundError: No module named 'regex'
    !!!!!!!!!!!!!!!!!!! Interrupted: 1 errors during collection !!!!!!!!!!!!!!!!!!!!
    =========================== 1 error in 0.96 seconds ============================

    And here is my code:
    import matplotlib
    from matplotlib import pyplot as plt

    from binance.client import Client
    import keys

    Client = Client(apikey,apisecret)

    klines_df =pd.Dataframe (Client.get_historical_klines("BTCUSDT",Client.KLINE_INTERVAL_1DAY,"1000 days ago UTC"))

    print(klines_df)

    posted in Pythonista read more
  • puckypuck

    @pulbrich

    Ok thanks for the support.
    I dont know what i do wrong, trying running the script and get error all the time

    posted in Pythonista read more
  • puckypuck

    @pulbrich

    I get the same
    module 're' from '/var/containers/Bundle/Application/

    posted in Pythonista read more
  • puckypuck

    @pulbrich
    Import re doesnt work, same error

    posted in Pythonista read more
  • puckypuck

    Hello,

    When i trying import data i get this error.

    import regex as re
    E ModuleNotFoundError: No module named 'regex’

    And another error when i try to import pandas

    ImportError: this version of pandas is incompatible with numpy < 1.13.3
    E your numpy version is 1.8.0.
    E Please upgrade numpy to >= 1.13.3 to use this pandas version

    I cant find where i can update the numpyversion.

    Hope someone can help me.

    posted in Pythonista read more
  • puckypuck

    @bennr01
    I dont know how but its working

    [~/Documents]$ pip install binance
    Querying PyPI ...
    Downloading package ...
    Opening: https://files.pythonhosted.org/packages/23/b4/566165409e9c851128988a990aba6bf14ebdf37fd847d0047ad16ae3d11b/binance-0.3-py2.py3-none-any.whl

    Save as: /private/var/mobile/Containers/Data/Application/EF98621A-F2BC-44E8-A079-7BB1B6C902BA/tmp//binance-0.3-py2.py3-none-any.whl (3839 bytes)
    3839 [100.00%]
    Installing wheel: binance-0.3-py2.py3-none-any.whl...
    Package installed: binance

    posted in Pythonista read more
  • puckypuck

    @bennr01
    [~/Documents]$ which pip
    ~/Documents/pip.py
    [~/Documents]$

    posted in Pythonista read more
  • puckypuck

    Thanks for reply!

    Now i’m feeling realy like a rookie.
    Where do i find the output?
    (Sorry)

    posted in Pythonista read more
  • puckypuck

    This is what i get:

    StaSh v0.7.2 on python 3.6.1
    Warning: you are running StaSh in python3. Some commands may not work correctly in python3.
    Please help us improving StaSh by reporting bugs on github.
    Tip: Bring a background job to foreground with fg JOB_ID
    [~/Documents]$ pip install binance
    Downloading https://github.com/ywangd/stash/archive/master.zip ...
    Unzipping into /private/var/mobile/Containers/Shared/AppGroup/09B9F2A0-A8A6-48F9-A9FF-5270C93BC17E/Pythonista3/Documents/site-packages/stash ...
    Preparing the folder structure ...
    Installation completed.
    Please Restart Pythonista and run launch_stash.py under the Home directory to start StaSh.
    [~/Documents]$

    posted in Pythonista read more

Internal error.

Oops! Looks like something went wrong!