• twotoed

    Thanks for the advice.
    I had a bit of a play around with things but the fix is a bit beyond my skill level at the mo.

    I keep running up against problems using Pythonista with these libraries (using matplotlib for animations doesn't seem to work either) so I think I'm going to give up on it for now and go back to using the PC.

    posted in Pythonista read more
  • twotoed

    Hi,
    I've tried installing matplotlib-venn on Pythonista using pip but I can't seem to get it to work.

    Instead I get a 'No module named scipy.sparse._sparsetools' error when trying to run it.

    When trying to install matplotlib-venn it also seems to try and install scipy as well, and I think it's done this incorrectly which is causing the problem.

    Any advice on how to resolve this would be greatly appreciated.

    posted in Pythonista read more
  • twotoed

    Thanks for that. I think I've now managed to update to the latest version.

    Just in case anyone else wants to do something similar in future, here's what I did:
    Installed stash: here
    Then in stash: pip install sympy
    There seemed to be a few error messages but checking the version using: import sympy ; print(sympy.__version__) seems to show the latest version so that's great.

    Again, thanks for the help.

    posted in Pythonista read more
  • twotoed

    Hi,

    I'm a beginner, just learning Python through the book 'Doing math with python' using Pythonista on my ipad and have run into the problem that some of the functions mentioned in the book aren't valid in my current version of sympy (0.7).

    Is there any way to update my sympy library to version 1.2 in Pythonista for ios?

    Any help would be appreciated.

    posted in Pythonista read more

Internal error.

Oops! Looks like something went wrong!