• theoriginalbudman

    brianryer hit it on the nose..

    posted in Editorial read more
  • theoriginalbudman

    Yes!

    That was what I was looking for.

    Thank you.

    What else have you got hidden up your sleeve?

    posted in Editorial read more
  • theoriginalbudman

    I've been working with the x-callback-ur scheme to try and send text from Drafts 4 to Editorial, but so far I've only succeeded in creating a blank file.

    I've create the following as a Drafts 4 action: editorial://x-callback-url/open?root=new&selection=0

    This invokes editorial but it opens with a new, blank file rather than opening the text created in Drafts 4.

    What am I doing wrong here?

    posted in Editorial read more
  • theoriginalbudman

    I did a little more digging and came up with this line of code: editorial://new/[[title]].md?root=local&input=[[body]]

    The parameters [[title]] and [[body]] are assigned by Drafts.

    There's been some progress. Invoking this code as a Drafts action creates the new file in Editorial, but for some reason the input text is not being pushed over. So all this does is creates a blank file in Editorial.

    Any suggestions?

    posted in Editorial read more
  • theoriginalbudman

    I've developed a couple of simple workflows that serve quite well for the type of writing I do. I've assigned icons and placed them on the bookmarks bar in the editor.

    But I'm having a hard time getting shortcuts to work!

    I use the key combinations I'd like assigned as short cuts, and they appear in the various data about each work flow, (e.g. ^b) but when I invoke the shortcut key combination the workflow does not execute.

    Am I doing something wrong?

    posted in Editorial read more
  • theoriginalbudman

    I gave that a try, and I've tried several other combinations since. Nothing seems to avail.

    For example, I have a very simple workflow that takes the selected text and wraps it in <sup></sup> (I do a lot of work with text that uses superscript). If I assign various shortcut key combinations (e.g., command+s, option+s, control+s or command+shift+s, option+shift+s & etc, or a symbol key or a number key) the workflow is not invoked.

    I have also noticed some odd behavior in digging further into this.

    • If I assign a keyboard combination (say, command+i) to a workflow, pressing that key alone without the "modifier key" (in this example just the i key without the command key), I hear a clicking sound if that key is pressed immediately to the right of white space, either as the first character in a new paragraph or after a space between words.

    • However, if I press that key immediately after another character, with no intervening white space, the i character appears!

    • I've tried this with various keys, symbols and numbers and get the same behavior in each case.

    So at the moment I'm stumped in re: the shortcut keys. I hope to find a solution soon, as this would be a very handy feature to have.

    I am using a New Trent keyboard on my iPad Air, which is running the most up to date version of iOS 8.0.2

    posted in Editorial read more
  • theoriginalbudman

    This would be an excellent feature, one that I've been wishing for myself.

    Here's how it would make my work much easier:

    • I use Ulysses III on my Mac at the office
    • If I want to keep files synced between U3 and Editorial (on my iPad), I have to use Dropbox
    • But using Dropbox results in some of U3's features being inaccessible. These features are only accessible if I am editing documents that are on my Mac or stored in the iCloud

    So having Editorial directly access files stored on iCloud would make my life a lot simpler.

    posted in Editorial read more
  • theoriginalbudman

    I have found that if I quit Editorial (not merely shift focus to another program) and then restart it, the problem "goes away." This doesn't tell us if the problem with in Editorial, in Dropbox or in the hand-off between them.

    posted in Editorial read more
  • theoriginalbudman

    I've run into an unusual program behavior I've not seen before. I attempted to rename a document I'd just created and received an error message:

    An Error occurred while renaming Untitled.md: Internal Server Error (500).

    Any idea what might be happening?

    posted in Editorial read more
  • theoriginalbudman

    I will take a stab at it!

    posted in Editorial read more

Internal error.

Oops! Looks like something went wrong!